MAESTRO Release Notes
MAESTRO is a finite element analysis program for rationally-based analysis, evaluation, and structural optimization of ships, offshore structures, and other large complex thin-walled structures.

MAESTRO Requirements
- Operating Systems tested: Windows Vista, 32-bit and 64-bit Windows 7, Windows 8 and 8.1
- Operating Systems not supported: Windows ME, 98, 95, NT
- Mac: The Intel Mac with Bootcamp or Parallels has not been tested
- Microsoft .NET Framework 3.5, SP1.
- Valid license (without this, MAESTRO will operate in the demonstration mode)
- Installation of Sentinel System Driver and Sentinel Protection Server 7.6.6. (Automatically installed with MAESTRO).

Version 11.2

New and Enhanced Modules
The following is a list of the new and enhanced modules found in MAESTRO v11.2. A copy of this list of features can be found in the Release Notes.

- ProColl Hull Module: ProColl Hull provides the ability to calculate compartment level progressive collapse behavior of lightweight aluminum ship structures and conventional steel vessels. This analysis method extends the interframe progressive collapse method by including overall gross panel buckling effects in the determination of hull girder strength.

New and Enhanced Features
The following is a list of the new and enhanced features found in MAESTRO v11.2. A copy of this list of features can be found in the Release Notes.

- User-Defined Longitudinal Hull Girder Stations: The user is now able to define non-uniformly spaced longitudinal stations to recover hull girder properties from.
- Large Model Handling: Several new features have been added to handle large models and analysis including parallel processing to read models faster and run fatigue calculations, and options to speed up group selection and creation.
- Nastran Export: Property names in a MAESTRO model can now be read into FEMAP.
- General Group CG Reported: The center of gravity of a general group is now reported along with the self-weight.
- Delete/Hide Element Dialogs: Evaluation patches have been added to the selection options for the Delete and Hide Elements dialogs.
• **Stiffener Layout Properties:** The stiffener layout create/modify/view functionality is now part of the plate, beam, rod, and spring properties dialog allowing sorting of stiffener layouts.

**Version 11.0**

**New and Enhanced Modules**
The following is a list of the new and enhanced modules found in MAESTRO v11.0. A copy of this list of features can be found in the Release Notes.

- **MAESTRO-Wave:** A new time-domain MAESTRO-Wave module has been added. In addition, new wet panel discretization options have been added for the frequency and time domain MAESTRO-Wave calculations including: 2D strip theory using the free surface Green’s Function, a high-speed 2.5D Rankine Source Method with forward speed correction, and the Universal RAO method. A new option to speed up computation time has been added to allow MAESTRO to calculate the velocity potential (thus radiation and diffraction pressure) as a constant value for all elements within the hydrodynamic panel instead of the standard method which calculates them on each FE element individually.

**New and Enhanced Features**
The following is a list of the new and enhanced features found in MAESTRO v11.0. A copy of this list of features can be found in the Release Notes.

- **Design Wave Creation:** The design wave dialog now allows the user to use a custom sea spectrum definition and also select which wave frequencies to use in determining the extreme design wave.
- **Operating Profiles and Wave Spectra:** A number of pre-defined operating profiles and wave spectra are now available with the MAESTRO distribution.
- **Mean and Extreme Stress Calculations:** A new capability has been added to compute mean stress and extreme stress from a computed RAO database.
- **RAO and Response Spectrum Calculations:** MAESTRO can now calculate motion and stress RAOs at specific locations/elements.
- **Inertia Relief Restraint Method:** A new automatic restraint method has been added in which the user does not have to apply traditional restraints to the model. Instead, MAESTRO automatically creates a fixed node at the model center of gravity which is attached to surrounding structure using soft spring elements. Inertia relief is required to be run prior to solving the model.
- **ABS High Speed Naval Craft Rules Added:** The stress and buckling checks from the ABS High Speed Naval Craft (ABS HSNC) guide have been added to MAESTRO’s limit state framework.
- **Import Mass Distribution from MAESTRO .wet File:** A MAESTRO .wet file can be re-imported into MAESTRO and used for a mass distribution. This allows a user to import a hydrodynamic mesh and full FE model mass distribution to run MAESTRO-Wave for motion and hull girder load RAOs.
• **Hide Elements:** A new command has been added under the View menu that allows a user to hide elements using a variety of selection options.

• **Group Operations and Group Manager:** Two new dialogs have been added allowing the user to more easily manipulate existing groups or create new ones. The Group Operations allows a user to create new groups by copying, adding, subtracting, or finding common elements between one or more existing groups. The Group Manager allows a user to move one or more groups into a new category or subfolder within the groups tree.

• **Bending Moment without Axial Force Contribution:** MAESTRO can now plot the longitudinal bending moment without axial force contributions which makes it easier to compare results to other tools that do not account for the axial force (e.g., section based calculations).

• **Merge Hydrodynamic Panel:** An option has been added to automatically merge evaluation panels into large panels to be used in hydrodynamic (MAESTRO-Wave) calculations.

• **Map Hydrodynamic Patch:** Allows the user to run MAESTRO-Wave with a custom hydrodynamic mesh of a structural model and map the source strengths from the hydrodynamic mesh to the structural model.

• **Level 1 Evaluation Patch Search:** A new evaluation patch search method has been added allowing the user to define the beam elements representing the patch boundary supports. The patch search/creation can now be performed on the current view part, in addition to the entire model. Also, the patch search functionality has been optimized to reduce computation time.

• **Negative Adequacy Parameter Reporting:** A new feature has been added to report the number of elements and corresponding structural weight of failing structure. All negative adequacy parameters, including minimum adequacy parameter, are now reported from the list elements command.

• **Weight Distribution Load Pattern:** The weight distribution algorithm has been improved to be more efficient.

• **Tank Load Reader:** A new import option allows the user to import a text file of tank loads to create one or more new load case definitions. Sample sources of this data include weight reports, spreadsheets, or a GHS tank load export script.

• **Polygon Mesh File Format Extended:** The polygon mesh file format has been extended to allow users to also import endpoint and strake definitions.

• **Beam Shapes Added:** The following beam shapes have been added: tube, box, and I.

• **Group Selection Options:** A variety of group selection options have been added including selecting by evaluation patches and adding by seed, attached properties, and attached beams.

• **Nastran Import Additions:** MAESTRO now imports concentrated masses and forces from NASTRAN models as well as preserves property names created in FEMAP. FEMAP Neutral (.neu) files can also be imported which preserve FEMAP group information.

• **MAESTRO-Wave Liquid Tank Loads:** New options have been added to the MAESTRO-Wave module to account for tank sloshing loads.
• **Directional Spring and GAP Element Added:** The existing spring element has been expanded to include directional springs and GAP elements.

• **Copy Elements:** A new feature has been added to quickly create one or more new elements in a selected direction by copying existing elements in the model.

• **Split Strake:** A new refinement option has been added allowing the user to “split” a strake into multiple strakes so that all stiffeners are now defined as girders.

• **ALPS/HULL Report:** A new option has been added to the ALPS/HULL results menu allowing the user to create a report of the ALPS/HULL results.

• **Multiple ALPS/HULL Results:** The ability to run and store ALPS/HULL results for more than one ALPS/HULL model has been added.

• **Design Pressure:** The design pressure option has been added back to the evaluation patch dialog allowing a user to specify an additional design pressure to be used for adequacy parameter calculations.

• **SN Curve Added:** The Eurocode 9 SN curve for aluminum has been added for spectral fatigue calculations.

• **Mass Distribution CG Calculator:** A new feature has been added to calculate a mass distribution’s VCG and TCG in order to reach a target VCG and TCG for the full load case.

**Bug Fixes:**

• **Element Directional Display:** This was feature was not working correctly in version 10.

• **Boundary Modules:** Bending moment and shear force loads for boundary modules were previously being applied as full value for a half model. Half models now use the half load value.

• **64-bit Cutting Plane Selection:** A bug with selecting cutting planes in the 64-bit version has been resolved.

• **Inertia Relief All Load Cases:** A bug was fixed that reset the static waterplane to the first load case when running inertia relief balance for all load cases.
**Version 10.0.5**

- **SFA Analysis with Top-Down Model**: The spectral fatigue analysis can now be run with top-down fine mesh models.

- **Operating Profile Enhancement**: The operating profile used with the ELA and SFA modules can now have unequal probabilities.

- **S-N Curve Parameters Now Visible**: The user is now able to view the parameters for the available S-N curves in MAESTRO.

**Bug Fix**: MAESTRO now allows multiple SFA groups to be created.

**Version 10.0**

New and Enhanced Features:

- **MAESTRO-Wave**: New module which provides the ship designer with an integrated frequency-domain computational tool to predict the motions and wave loads of any vessel. To compute these hydrodynamic motions and loads, MAESTRO-Wave first calculates the velocity potentials, source strengths, and flow velocities at the centroids of the hydrodynamic panels for each speed, heading, and frequency requested, and then maps the source strength to the structural panels. The equations of motion are formulated using the structural mesh rather than the hydrodynamic mesh. This approach results in a perfect equilibrium for the structural model. Bending moments, shear forces and torsional moments are automatically in closure. No inertia relief and artificial loads are needed to balance the model. The computation of these hydrodynamic forces is based on 3D potential theory using the zero speed Green's function with a speed correction parameter. A variety of visualizations and output data are available for purposes of post-processing.

- **Extreme Load Analysis (ELA)**: New module which imports unit wave load data from a hydrodynamic analysis (MAESTRO-Wave or other) via *.smn file format. It then allows the user to calculate hull girder load response RAOs, and provides the necessary short-term and long-term statistical computations to predict extreme values of the maximum loads for a given vessel.

- **Spectral Fatigue Analysis (SFA)**: New module which provides the ability to perform global fatigue screening of the vessel. The SFA module introduces additional functionality to the ELA module to compute Stress RAOs, displacement RAOs, define and associate structural groups to SN curves and Stress Concentration Factors (SCFs), and compute fatigue damage based on the Miner cumulative damage principle.

- **MAESTRO/NAPA Steel Interface**: New module which allows the designer to import a NAPA/NAPA Steel 3D model, which includes the finite element model (geometry, scantling properties, and finite elements), loading information (longitudinal weight and bending moment distributions, tank boundary/content/fill definitions, and hydrostatic equilibrium definition), and model hierarchy definitions such as MAESTRO module group. This interface enables shorter design cycle times by using a single 3D structural design model (from NAPA) that can be re-used as the design matures and is ready for analysis in a matter of minutes.
• **VERES Export:** Allows user to export MAESTRO model information to *.MGF, *.M3D, and *.M2D files to support VERES analyses.

• **PRECAL Export:** Allows user to export MAESTRO model information to *.HUL, *.HIN, and *.CND files to support PRECAL analyses.

• **64-bit Version:** Now available in a 64-bit version.

• **ALPS/ULSAP Update:** This module has been updated to version 2011.2.

• **Results View Updates:** When user-defined range is set, elements below that range are set to blue and elements above that range are set to red.

• **Expanded Group Organization Feature:** Allows subfolders to be created underneath the default group types in the groups tree.

• **Drag and Drop Group Creation:** Groups may now be dragged and dropped from one type to another to automatically extract certain elements from an existing group. For example, nodal groups can be created from plate or general group and shell elements may be recovered from node groups or a general group.

• **New Tank Features:** Allows volume groups to be defined as flooded to model flooded or damaged conditions. User can adjust tank permeability and apply deballast pressure.

• **Hull Girder Load Target:** The hull girder load target is a new load pattern that can be used to ensure that either a minimum shear force envelope or a minimum bending moment envelope is met or to add an additional shear force or bending moment on top of all other load patterns.

• **Create Boundary Modules:** Option to assist in applying end moments. A master node is automatically created and joined by RBE2 elements to all nodes at modules ends to ensure that plane sections remain plane. End Moment load is then applied at this master node.

• **Weight and Buoyancy Density Plot:** Option to plot weight and buoyancy per unit length for easier comparison to other hydrostatic programs.

• **Create Module from General Group:** Right-click menu option to create a new module consisting of the elements defined in the selected general group. These elements are removed from their original module.

• **Extract Module:** Option to create a new module by “extracting” elements from an existing module by defining a bounding box. This allows large or full ship imported models to be easily separated into more manageable modules.

• **Define General Group from List of Nodes or Elements:** Select multiple elements/nodes from the grid tab and create a general group using the right-click menu.

• **Mass Distribution Exclude Nodal Groups:** The mass distribution load pattern now allows selected nodal groups to be excluded from receiving the loading.

• **Speed Enhancements:** MAESTRO’s loading speed has been increased for models with large numbers of groups defined. The auto-creation of evaluation patches has also been increased to handle larger and finer meshed models.

• **Displacement Direction Plot Added:** Option to select single direction (i.e. X, Y, Z) only to plot deformation. Also added option to plot “true” scale deformation.

• **Cutting Planes added to Right-Click Menu:** The same cutting planes menu that appears in the Tools menu is now added to the menu when you right-click the mouse in the modeling space.
Bug Fixes: A number of minor bugs have been fixed.

Version 9.1.0

New and Enhanced Features:

- **User Defined Extreme Design Wave**: Capability to facilitate Extreme Load Analysis has been added to the MAESTRO main menu. This includes the ability to graphically review an imported load database (via complex Ship Motion file) and the creation of extreme design loads.

- **Ship Motion File Complex Form**: The Ship Motion file has been expanded to allow the importing of Complex displacement, acceleration, and pressure data calculated by 3rd party seakeeping software. This file is backward compatible with the legacy Ship Motion file.

- **Weight Distribution Load Pattern**: Added the ability to generate a weight distribution by either entering weights or weight densities at their corresponding longitudinal locations. This load pattern can be combined with other existing load patterns.

- **New Midship Section Design Tutorial**: This tutorial will walk through the complete process of creating and analyzing a midship section given a basic set of design parameters and hull geometry.

- **Group Creation & Modification**:
  - Added a method to facilitate the identification of wetted elements
  - Added several methods for creating General groups and Volume groups including an automatic search algorithm
  - Added methods to automatically generate consistent normals within a group
  - Ability to add elements during group creation from the groups view

- **Nastran Import/Export**: The following functionality has been added to the Nastran import/export capability:
  - Significantly improved the importing speed
  - Import Spherical and Cylindrical coordinate
  - Import/Export PBARL/PBEAML cards
  - Export "boundary only" data file (filename.nas.spcd)
  - Import Nastran model as a Group

- **Hull Girder Cross Section Property Calculation**: A new method for defining cross section locations has been added. This functionality allows you to recover hull girder section properties outside of the traditional endpoint locations. This includes recovering hull girder properties from an imported Nastran finite element model.

- **Equation Solver Method**: The mechanism to choose a different Equation Solver method (Sparse, Iterative, or Skyline) has been moved to the File/Preferences dialog. Previously, this mechanism was located in the Analysis/Evaluation dialog.

- **Longitudinal Effectiveness**: Added the ability to assign longitudinal effectiveness to finemesh models and General groups.
• **ALPS/ULSAP:** This module has been significantly updated to the version 2010.4. Additional reference papers have been added to the Help system as well as updated verification models.

• **ALPS/HULL:** This module has been updated to allow the user to impose pressures (i.e., hydrostatic, volume, linpress, etc.) on the defined ALPS/HULL analysis model.

• **Simple Object Mesh Template:** Added the ability to auto-generate the following MAESTRO models:
  - Stiffened Panel with Initial Deflection
  - Sphere
  - Cylinder with/without rings

• **Sample Models:** Security changes have been made in Windows 7. Therefore, if MAESTRO is installed on a Windows 7 OS, the Models and Samples directory will be located in C:\ProgramData\MAESTRO directory.

• **Ply-Polygon File Format Import:** MAESTRO now has the ability to import ply-polygon mesh geometry files (*.ply). This feature will create a new module of the quad and triangle elements in the mesh, all with the same plate and material property.

**Bug Fixes:** A number of minor bugs have been fixed.

**Known Issues:**

• **Cutting Planes:** Cutting planes deleted when user chooses View/Refresh.

• **Quick Create:** The creation of additional nodes via *Quick Create* fails on the first attempt in some cases.

• **Color Legend:** In some plotting scenarios, the titles and/or values are cutoff. The user can use the View/Options to change the font if necessary.

• **Default Material:** The default material property is deleted when the user creates a new model (via the File/New menu item) in one running instance of MAESTRO.

• **View Refresh:** In plotting different views, MAESTRO will *hang* on the current view. In most cases this can be resolved by the user choosing View/Element Type followed by View/Refresh.

• **Cylindrical Coordinates:** The cylindrical coordinates were intended for purposes of inputting the data but not modifying existing Endpoints/Additional Nodes.
**Version 9.0.8**

New and Enhanced Features:

- **Sparse Out-Of-Core (OOC) Solver:** Added Sparse Out-Of-Core (OOC) solver that can solve very large models. The limitation of the solver is based on the computer's hard disk space. Models up to 700,000 degrees of freedom have been tested.

- **Inertia Balance:** Added automated inertia balancing for models having hydrostatic loading. Previously, automated inertia balance was only available for models not having hydrostatic loading. The details of the load balance methodology are available under Load Balance in the Verification and Validation section of the manual.

- **Longitudinal Bending Moments:** Axial forces for longitudinal bending moment calculations are now included. Previously, the bending moment distribution was based on the classical beam theory, where the contributions from axial forces were ignored. In some cases, this resulted in bending moment distributions that did not close at the ends. This only affects the bending moment distribution plot and does not change the model's loads; therefore, this will not change previous model response results. The details of the longitudinal bending moment calculations are available under Load Balance in the Verification and Validation section of the manual.

- **Bending Moment/Shear Plots:** Bending moment and shear force are now plotted at the base line. Previously, these plots were located at the waterline.

- **Load Balancing Verification Documentation:** An extensive explanation and verification of the load balancing methodology is presented in the Help file.

Bug Fixes:

- **Legacy Solver:** Fixed a few synchronization bugs for the legacy solver.

- **Load Creation:** Fixed a bug related to the numbering of load cases. If the user only had two load cases, ID 2 and ID 3, but missing ID 1, a third load case could not be created unless ID 3 was renumber to 1 or 4.

- **Fine Mesh Models and Corrosion:** Fixed a bug when solving un-corroded fine mesh models of a corroded global model.

- **ALPS/HULL:** Fixed a bug that did not allow the user to execute an ALPS/HULL analysis a second time in a given session.

- **RSpline:** Fixed an RSpline display bug that caused computer crashing when creating/deleting RSplines.

Graphical Bugs Fixed:

- **Stress Reporting:** A bug when reporting stress for transversely stiffened elements.

- **Group View Deformation:** Deformation plots when viewing groups were not correct.

- **Adequacy Plots:** Fixed a bug when displaying adequacy parameters of irregular evaluation patches.

**Version 9.0.7**
New and Enhanced Features:

- **Layout Organization:** Many of the menu items and icons have been reorganized, renamed or changed to provide the user with a more consistent and effortless experience. Please see the documentation for a complete description of menus and icons.
- **RBE3:** A new element, RBE3 has been added to MAESTRO. The intended use of the RBE3 is to transmit forces and moments from a primary node to one or more secondary nodes without adding any stiffness to the structure.
- **Transverse Bending Moments:** A newly designed Hull Menu includes options to view transverse plots of bending moments. This is especially useful when designing multi-hulls.
- **Transparency:** This new feature allows the user to choose to set a module or substructure as transparent for easier viewing of the model.
- **Groups Creation/Operation:** New functionality has been added to allow a user to create a new group from existing groups using the Group Operation dialog. Also, a new feature has been added within the groups dialog to add additional elements that are similar to an already selected element. Combined, these features provide the user with a more robust way to create groups.
- **Wetted Group:** To assist in exporting "wetted" elements to FEMAP, new functionality in the Groups menu was added that will automatically create a general group of "wetted" elements.
- **Select by Box:** To expedite the selection of elements, a select-by-box capability has been added.
- **Directional Stress:** A new feature has been added which allows the user to align all element local stress vectors to a global direction. This functionality will enable the presentation of stress in a uniform manner to the analyst can better assess the stress patch in a given direction.
- **Export Stiffness Matrix:** MAESTRO can now export the stiffness matrix in Nastran format through the export Nastran options. This feature will allow advanced users to process analysis runs in Nastran by using the MAESTRO generated stiffness matrix.
- **Batch Execution:** MAESTRO has the ability to perform batch processing, which allows the user to sequentially solve any number of models, each of which may have any number of load cases without having to manually launch each model.
- **AutoSave:** A new auto save feature has been added to MAESTRO. The user can select the number of executed commands in between auto saves from File > AutoSave Frequency.
- **Recover Model:** A new feature has been added under File > Recover, which automatically recovers a model after an unexpected closing of MAESTRO.
- **Documentation:** The documentation has been completely overhauled with a focus more on "how to." Additionally, all of the documentation is now in a single location, which can be found via the Help menu or help icon.
- **Sentinel Security Drivers/Servers:** The Sentinel System Driver (both for USB) and Sentinel Protection Server (for Network locks) are now integrated into the MAESTRO installation process. Therefore, there is no need for the user to install security drivers/servers separately. The integrated installation checks to determine the necessity of installing the Sentinel Driver/Sentinel Protection Server.
- **Help Menu:** The new Help menu now includes links to the website, forum, support email, and FAQ.
- **FAQ:** Updated FAQ section in the help file and on the website.
- **"Null" Beam and Stiffener Properties:** There are now predefined "null" beam and stiffener layouts when creating a new model. This eliminates the need to define these for an unstiffened panel or unframed strake.
• **Set Current & View Part:** There is now an icon and a right-click menu option in the parts tree to set the current and view part for a module or substructure at the same time. There is also a new icon to set current part and set view part.

• **Background Color:** The new MAESTRO default background color is light gray with gradient north. To change back to a black background, or another color, open the Preferences dialog from File > Preferences.

• **Capture View:** A new feature has been added under the File menu which allows the user to copy a screenshot of the modeling space to their clipboard which can then be pasted into another program.

• **Importing Legacy Results:** A new mechanism has been added to facilitate the importing, i.e. opening *.PLG files, of legacy MAESTRO results.

• **Hull Menu:** A newly designed Hull Menu with options to view horizontal and transverse plots.

• **Solving Fine Mesh Models:** Multiple top down Fine Mesh models can be solved at once from the File > Analysis/Evaluation menu or Analysis/Evaluation dialog.

• **Groups:** A new feature has been added within the groups dialog to add additional elements that are similar to an already selected element.

• **Check & Merge Dialog:** The functionality found in the Check & Merge Dialog (namely Update: FE Tags, Free Edges and Evaluation Patches) has been moved to the Tools > Renumber FE-Tag, View > Edges > Free Edges and Model > Evaluation Patch > Auto-Generate menu items respectively.

• **Model Summary:** Functionality used to report number of elements and nodes has been moved to the Model > Summary menu item.

**Bug Fixes:**

• **Update FE Tags:** Fixed a bug so that FE Tags are updated when a module or substructure is moved or rotated.

• **Collapsed Quad:** Fixed a bug so that a quad collapsed to a triangular element correctly distributes mass and force to the appropriate nodes.

• **Sort Volume Table:** Fixed a bug so the Volume Table can now be sorted by the Volume Group Name.

• **Deletions Dialog:** Fixed a bug that would cause a hard crash when deleting large amounts of elements from the deletions dialog.

• **Sort Element List by ID:** Fixed a bug that allows elements to be sorted in the Grid tab without information disappearing.

• **Sort Nodes List by ID:** Fixed a bug that caused a hard crash when trying to sorted listed nodes by ID in Grid tab.

• **Warped Quad:** Fixed a bug to take the average face normal of the two triangles making up a warped quad for area, weight, volume, etc. calculations.

• **Trochoidal Wave:** Fixed a bug so that the trochoidal wave profile definition now uses the formulas provided in DDS-100-6 i.2.

• **Parts Tree in Parts Dialog:** Fixed a bug so that the parts tree within the Modules and Substructures dialog is consistent with the main parts tree.

• **Brackets:** Fixed a bug so that leg lengths are automatically populated for the listed property, and are returned to the automatic lengths if “user defined” is unchecked.

• **Find FE-Tag:** Fixed a bug so a search can now be performed for a nodal or elemental FE-Tag.
- **Deletions Filters**: Fixed a bug so that the filters in the deletions dialog work as expected.
- **Saving/Loading Results**: Fixed a bug so results consistently save and load with a .mdl file.
- **ULSAP Results**: Fixed a bug so that ULSAP results are automatically saved and loaded with a .mdl file.
- **ULSAP Adequacy Parameters**: Fixed a bug so only ULSAP Adequacy parameters are shown in an ULSAP analysis.

**Graphical Bugs Fixed:**

- **"Show This Thickness Only"**: Fixed a bug that allows user to switch back to all "thicknesses" using the dynamic query once the "Show this thickness only" option is selected.
- **Corner Stress**: Fixed a bug so now the check box for "Corner Stress" changes the stress contour plot between nodal and elemental contour plots.
- **Compound Element Effectiveness**: Fixed a bug so now non-transverse compound elements can be defined as longitudinally effective using the dynamic query.
- **Bending Moment when Switching Load Cases**: Fixed a bug so the hull bending moment plot updates when different load cases are selected.
- **Load Case Selection**: Fixed a bug to make sure queried loads are consistent with the load case from the load case selection drop-down menu.
- **Pressure Plots when Switching Load Cases**: Fixed a bug so the color plot and legend updates each time a different load case is selected from the load case drop-down menu.
- **Deformed Model Changes**: Fixed a bug that prevented model from being undeformed if structure was changed in the "deformed" mode.
- **Contour Stress Plot**: Fixed a bug so that the stress legend updates correctly between load cases when viewing a contoured stress plot.
- **Hide Elements Outside Range**: Fixed a bug that now has Hide Elements Outside Range icon functionally properly. This option will now hide elements that are not within the range of displayed values.
- **Stiffeners on Wetted Elements View**: Fixed a bug so that when stiffeners are turned on, they remain in view on the wetted elements when selecting View > Wetted Elements.
- **Mirrored Wetted Elements**: Fixed a bug so the wetted faces of wetted elements in a mirrored module or substructure are shown correct graphically.
- **Adequacy “User Defined” Range Plot**: Fixed a bug so results update correctly when switching between load cases.